Topic: Anyone Able To Help?

I'm building my first dynamic website with flash for a sr. high youth group. I've done many
many hours of watching the videos on lynda.com, and I thought I was
ready, but I'm not so sure... I'll try to explain my problem as
precise as possible:

Here are my files:
master.swf
sharedlib.swf
sharedlibtrigger.swf
preloader.swf
main.swf
(There will be more eventually...)

The master has this code on the first keyframe of the actions layer:

stop();

//---------------------<MCL>-----------------------\\
var myMCL:MovieClipLoader = new MovieClipLoader();
var myListener:Object = new Object();

myMCL.addListener(myListener);

myListener.onLoadProgress = function(target_mc:MovieClip,
loadedBytes:Number, totalBytes:Number) {
_level50._visible = true;
var preloadPercent:Number = Math.round
((loadedBytes/totalBytes) * 100);
_level50.preloader.gotoAndStop(preloadPercent);
}

myListener.onLoadComplete = function(target_mc:MovieClip) {
_level50._visible = false;
}
//---------------------</MCL>-----------------------\\

// trigger the MCL to load these assets
myMCL.loadClip("preloader.swf", 50);
myMCL.loadClip("sharedlibtrigger.swf", 5);

//---------------------<LoadVars>-------------------\\
var myLV:LoadVars = new LoadVars();
myLV.onLoad = function(success:Boolean) {
if (success) {
// text will be loaded into a dynamic text field
// with the instance name of "loadedInfo". To
// reuse this LoadVars object, name ALL text fields
// the same instance name, namely "loadedInfo"
_level5.loadedInfo.htmlText = myLV.info;
} else {
_level5.loadedInfo.text = "There has been an error
loading the requested information. Please contact the webmaster and
report your error";
}
}
//---------------------</LoadVars>-------------------\\



The sharedlibtrigger.swf should load the sharedlib.swf into the cache
and when that is done, it tells master.swf to go on playing. The
10th frame of master.swf action layer has this code:

stop();
myMCL.loadClip("main.swf", 5);


The main.swf loads eventually and correctly, however, in the loading
of the sharedlib and the preloader, the preloader seems to dissapear
instantly and be gone until the main.swf is loaded.

What I want to happen is the preloader shows up first, and stays on
the screen while the browser loads the sharedlib.swf and the
main.swf. Maybe I've got my whole code design wrong, I don't know,
but I feel like I'm at a dead end. Any help would be appreciated!

Re: Anyone Able To Help?

Never mind on that.  I was able to solve my own problem.  My preloader.swf was just setup wrong.  I'm good to go now.