Topic: 2.2.2 ActionMailer not working

I'm working on a new project that uses ActionMailer but test emails are not showing up in my mailbox although my developer log files shows a copy of it. I've tried :smtp through my hosting company and get a timeout error. When I try :sendmail, it says that they email is sent but it never arrives.

I've tried the following configuration in my environment.rb file for sendmail.

  config.action_mailer.delivery_method = :sendmail
  config.action_mailer.raise_delivery_errors = true
  config.action_mailer.perform_deliveries = true
  config.action_mailer.default_charset = "utf-8"

I setup an initializer file for smtp (which I also tried in environment.rb) like the following:

ActionMailer::Base.raise_delivery_errors = true
ActionMailer::Base.perform_deliveries = true
ActionMailer::Base.default_charset = "utf-8"
ActionMailer::Base.delivery_method = :smtp
ActionMailer::Base.smtp_settings = {
    :address => "",
    :port => 25,
    :domain => "",
    :user_name => "username",
    :password => "password",
    :authentication => :login

I also tried this in my initializer file:

ActionMailer::Base.delivery_method = :sendmail 
ActionMailer::Base.perform_deliveries = true 
ActionMailer::Base.raise_delivery_errors = true 
ActionMailer::Base.default_charset = "utf-8"

Any guidance would be appreciated.

I'm running on a Mac with 10.4.11.

"And he has commited to us the message of reconciliation, ..." 2 Cor. 5:19,20